Estás navegando como visitante. Por favor Registrate y Logueate para poder participar de ventajas como postear en el foro, Solicitar Ayuda, Ver Enlaces, Ver Imagenes. Registrate con nosotros clickeando AQUÍ.    
Registrarse    Identificarse   Blogs
Anuncios Internos

Quieres ser Moderador/a. Si estas interesado/a, lee la info sobre ésto, haciendo Click
Promociona tu web AQUÍ

En ésta web está expresamente prohibido, publicar enlaces de descargas de material protegido por la ley, asi como seriales, cracks, parches, programas o juegos pirateados sin el consentimienteo del autor, en cuyo caso se debará exibir dicha autorización para legitimizar la descarga. Si algun usuario incumple esta norma, sera
eliminado junto a todos sus mensajes.


Portal » Índice general » Zona Webmasters » PhpBb3 » Consultas Phpbb3




Nuevo tema Este tema está cerrado, no puede editar mensajes o enviar nuevas respuestas  [ 2 mensajes ] 
{ VISITS } Vistas: 1198  { VISITS } Favoritos: 0  | { VISITS } Seguidores: 2 
Seguidores: Carls, Megabyte
 
Autor Mensaje
 Asunto: Pequeño problema con SEO MOD REWRITE URL  [SOLUCIONADO]
 Nota Publicado: 12 Sep 2011 22:13 


Desconectado
Usuario
Usuario
Avatar de Usuario

Mensajes: 86

Todos mis aportes


Nivel: 8

HP: 0 / 159
0 / 159 0 / 159 0 / 159
MP: 76 / 76
76 / 76 76 / 76 76 / 76
EXP: 86 / 100
86 / 100 86 / 100 86 / 100

Karma: 0

Ubicación:Chiclana de la Frontera,Cádiz


Sexo:
Masculino



He dado: 5 Gracias
Recibidas: 1 Gracias
Blog: Ver blog (0)
Hola Pc-teros! que tal estais? bueno os hago una consulta de nuevo. Se trata de nuevo con el mod seo url rewrite xD Sigo teniendo problemas. La última vez que me lo solucionasteis funcionaba en parte si y parte no. Porque por ejemplo supongamos q tengo un post en comunidad zdv entonces la url quedaria asi: Debe registrarse para ver este enlace. Gracias por su visita. . Entonces errores por un tubo, con los rangos tampoco me los cogia bien. Bueno he estado toqueteando un poco y algo lo he mejorado, ahora funcina todo lo que he dicho que no funciona. Funciona el index funcionan los post pero no las categorias ni los perfiles. Aquí os dejo un ejemplo:

Debe registrarse para ver este enlace. Gracias por su visita.

zonadelvicio.com/foro/carls-u2.html

Mi .htaccess:
Debe registrarse para ver este enlace. Gracias por su visita.
  •     # STARTED : 01/2006
  •     #################################
  •     # FORUMS PAGES
  •     ###############
  •     # FORUM INDEX REWRITERULE WOULD STAND HERE IF USED. "forum" REQUIRES TO BE SET AS FORUM INDEX
  •     # RewriteRule ^foro/forum\.html$ /foro/index.php [QSA,L,NC]
  •     # FORUM ALL MODES
  •     RewriteRule ^foro/(forum|[a-z0-9_-]*-f)([0-9]+)/?(page([0-9]+)\.html)?$ /foro/viewforum.php?f=$2&start=$4 [QSA,L,NC]
  •     # TOPIC WITH VIRTUAL FOLDER ALL MODES
  •     RewriteRule ^foro/(forum|[a-z0-9_-]*-f)([0-9]+)/(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /foro/viewtopic.php?f=$2&t=$4&start=$6 [QSA,L,NC]
  •     # GLOBAL ANNOUNCES WITH VIRTUAL FOLDER ALL MODES
  •     RewriteRule ^foro/announces/(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /foro/viewtopic.php?t=$2&start=$4 [QSA,L,NC]
  •     # TOPIC WITHOUT FORUM ID & DELIM ALL MODES
  •     RewriteRule ^foro/([a-z0-9_-]*)/?(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /foro/viewtopic.php?forum_uri=$1&t=$3&start=$5 [QSA,L,NC]
  •     # PHPBB FILES ALL MODES
  •     RewriteRule ^foro/resources/[a-z0-9_-]+/(thumb/)?([0-9]+)$ /foro/download/file.php?id=$2&t=$1 [QSA,L,NC]
  •     # PROFILES ALL MODES WITH ID
  •     RewriteRule ^foro/(member|[a-z0-9_-]*-u)([0-9]+)/$ /foro/memberlist.php?mode=viewprofile&u=$2 [QSA,L,NC]
  •     # USER MESSAGES ALL MODES WITH ID
  •     RewriteRule ^foro/(member|[a-z0-9_-]*-u)([0-9]+)/(topics|posts)/?(page([0-9]+)\.html)?$ /foro/search.php?author_id=$2&sr=$3&start=$5 [QSA,L,NC]
  •     # GROUPS ALL MODES
  •     RewriteRule ^foro/(group|[a-z0-9_-]*-g)([0-9]+)(-([0-9]+))?\.html$ /foro/memberlist.php?mode=group&g=$2&start=$4 [QSA,L,NC]
  •     # POST
  •     RewriteRule ^foro/post([0-9]+)\.html$ /foro/viewtopic.php?p=$1 [QSA,L,NC]
  •     # ACTIVE TOPICS
  •     RewriteRule ^foro/active-topics(-([0-9]+))?\.html$ /foro/search.php?search_id=active_topics&start=$2&sr=topics [QSA,L,NC]
  •     # UNANSWERED TOPICS
  •     RewriteRule ^foro/unanswered(-([0-9]+))?\.html$ /foro/search.php?search_id=unanswered&start=$2&sr=topics [QSA,L,NC]
  •     # NEW POSTS
  •     RewriteRule ^foro/newposts(-([0-9]+))?\.html$ /foro/search.php?search_id=newposts&start=$2&sr=topics [QSA,L,NC]
  •     # UNREAD POSTS
  •     RewriteRule ^foro/unreadposts(-([0-9]+))?\.html$ /foro/search.php?search_id=unreadposts&start=$2 [QSA,L,NC]
  •     # THE TEAM
  •     RewriteRule ^foro/the-team\.html$ /foro/memberlist.php?mode=leaders [QSA,L,NC]
  •     # HERE IS A GOOD PLACE TO ADD OTHER PHPBB RELATED REWRITERULES
  •  
  •     # FORUM WITHOUT ID & DELIM ALL MODES (SAME DELIM)
  •     # THESE THREE LINES MUST BE LOCATED AT THE END OF YOUR HTACCESS TO WORK PROPERLY
  •     RewriteCond %{REQUEST_FILENAME} !-f
  •     RewriteCond %{REQUEST_FILENAME} !-d
  •     RewriteRule ^foro/([a-z0-9_-]+)/?(page([0-9]+)\.html)?$ /foro/viewforum.php?forum_uri=$1&start=$3 [QSA,L,NC]
  •     # FIX RELATIVE PATHS : FILES
  •     RewriteRule ^foro/.+/(style\.php|ucp\.php|mcp\.php|faq\.php|download/file.php)$ /foro/$1 [QSA,L,NC,R=301]
  •     # FIX RELATIVE PATHS : IMAGES
  •     RewriteRule ^foro/.+/(styles/.*|images/.*)/$ /foro/$1 [QSA,L,NC,R=301]
  •     # END PHPBB PAGES
  •     #####################################################
  •  
  •  


  • Mi phpbb_cache.php:

    Debe registrarse para ver este enlace. Gracias por su visita.
  •     * @package Advanced phpBB3 SEO mod Rewrite
  •     */
  •     if (!defined('IN_PHPBB')) {
  •        exit;
  •     }
  •     $this->cache_config['settings'] = array ( 'url_rewrite' => true,
  •     'modrtype' => 3, 'sql_rewrite' => true, 'profile_inj' => true, 'profile_vfolder' => false, 'profile_noids' => true, 'rewrite_usermsg' => true, 'rewrite_files' => false, 'rem_sid' => false, 'rem_hilit' => true, 'rem_small_words' => false, 'virtual_folder' => true, 'virtual_root' => false, 'cache_layer' => true, 'rem_ids' => false, 'copyrights' => array ( 'img' => false, 'txt' => '', 'title' => '', ), 'zero_dupe' => array ( 'on' => true, 'strict' => false, 'post_redir' => 'all', ), 'no_dupe' => array ( 'on' => true, ), );
  •     $this->cache_config['forum'] = array ( 3 => 'comunidad-zdv-f3', 5 => 'el-rincon-de-zdv-f5', 6 => 'off-topic-f6', 7 => 'sugerencias-de-la-web-f7', 32 => 'foro-staff-f32', 58 => 'noticias-en-la-web-f58', 59 => 'noticias-zdv-f59', 60 => 'noticias-ps3-f60', 61 => 'noticias-xbox-f61', 62 => 'noticias-psp-f62', 63 => 'noticias-wii-f63', 64 => 'noticias-nds-f64', 76 => 'noticias-pc-f76', 86 => 'noticias-multiplataformas-f86', 8 => 'playstation-f8', 9 => 'general-f9', 13 => 'juegos-f13', 14 => 'trucos-y-guias-f14', 30 => 'analisis-f30', 15 => 'online-f15', 16 => 'scene-ps3-f16', 79 => 'downgrades-f79', 80 => 'hardware-dongles-f80', 81 => 'customfirmwares-cfw-f81', 82 => 'programas-y-software-f82', 83 => 'manuales-de-carga-f83', 84 => 'carga-de-backups-f84', 85 => 'firmware-oficiales-f85', 65 => 'homebrew-f65', 10 => 'xbox-f10', 17 => 'general-f17', 18 => 'juegos-f18', 19 => 'trucos-y-guias-f19', 20 => 'online-f20', 21 => 'scene-f21', 11 => 'wii-f11', 22 => 'general-f22', 23 => 'juegos-f23', 24 => 'trucos-y-guias-f24', 25 => 'scene-f25', 26 => 'pc-f26', 28 => 'general-f28', 29 => 'juegos-f29', 31 => 'analisis-f31', 77 => 'programacion-f77', 78 => 'consultas-tecnicas-f78', 33 => 'psp-f33', 34 => 'general-f34', 35 => 'juegos-f35', 36 => 'scene-f36', 37 => 'nds-f37', 38 => 'general-f38', 39 => 'juegos-f39', 40 => 'scene-f40', 51 => 'manuales-f51', );
  •     ?>


  • Gracias de antemano, haber si conseguimos solucionarlo!

    -- 13 Sep 2011 00:13 --

    resuelto genere el .htaccess a la raiz de la carpeta del foro!

    firma

    Este es el lugar para tu firma

    Personaliza tu perfil



    Pc-teros Community - www.pc-teros.es
    Arriba 
     Perfil  
     
     Asunto: Re: Pequeño problema con SEO MOD REWRITE URL
     Nota Publicado: 19 Sep 2011 04:04 


    Desconectado
    Del equipo
    Del equipo|Del equipo|Del equipo
    Avatar de Usuario

    Mensajes: 1175

    Todos mis aportes
    Estado de ánimo: Feliz


    Nivel: 29

    HP: 85 / 2142
    85 / 2142 85 / 2142 85 / 2142
    MP: 1022 / 1022
    1022 / 1022 1022 / 1022 1022 / 1022
    EXP: 1175 / 1181
    1175 / 1181 1175 / 1181 1175 / 1181

    Karma: 61

    Ubicación:Guatelinda, C.A.


    Sexo:
    Masculino



    He dado: 135 Gracias
    Recibidas: 259 Gracias
    Blog: Ver blog (4)
    que bueno q lo resolviste, y mejor q dejaste la respuesta....

    bien.. b10:

    firma
    Imagen

    Imagen

    Imagen


    Pc-teros Community - www.pc-teros.es
    Arriba 
     Perfil  
     
    El siguiente usuario da las gracias a Megabyte por ese mensaje:
    blquack
    Mostrar mensajes previos:  Ordenar por  
     
    Nuevo tema Este tema está cerrado, no puede editar mensajes o enviar nuevas respuestas  [ 2 mensajes ] 


    ¿Te fue util este tema?

    Link:
    BBcode:
    HTML:


    Temas Similares


    Portal » Índice general » Zona Webmasters » PhpBb3 » Consultas Phpbb3


    Temas relacionados
     Temas   Autor   Comentarios   Vistas   Último mensaje 
    No hay nuevos mensajes sin leer en este tema. Mod Rewrite de Apache y .htacces

    blquack

    2

    278

    13 Feb 2011 02:54

    blquack Ver último mensaje

    No hay nuevos mensajes sin leer en este tema. Duda sobre el .htaccess url rewrite en MKportal y phpbb3

    [ Ir a páginaIr a página: 1, 2 ]

    Carls

    14

    1050

    09 Abr 2011 21:43

    blquack Ver último mensaje

    No hay nuevos mensajes sin leer en este tema. Adjunto(s) problema con STK

    martinkly

    5

    274

    23 Abr 2011 12:59

    blquack Ver último mensaje

    No hay nuevos mensajes sin leer en este tema. Problema con un div

    miriamgomez

    3

    671

    21 Oct 2013 20:25

    miriamgomez Ver último mensaje

    Este tema está cerrado, no puede editar mensajes o enviar nuevas respuestas Problema con 1 mensaje

    uruguayito

    3

    235

    08 Dic 2010 00:33

    blquack Ver último mensaje

    No hay nuevos mensajes sin leer en este tema. problema extraño!

    martinkly

    9

    252

    17 Feb 2011 21:14

    blquack Ver último mensaje

    No hay nuevos mensajes sin leer en este tema. Adjunto(s) problema friend_list_1.0.3

    [ Ir a páginaIr a página: 1, 2, 3, 4 ]

    martinkly

    39

    1223

    05 Abr 2012 13:00

    blquack Ver último mensaje

    No hay nuevos mensajes sin leer en este tema. Adjunto(s) problema con mod gracias

    [ Ir a páginaIr a página: 1, 2 ]

    z3rito

    11

    506

    17 Abr 2011 21:25

    blquack Ver último mensaje

    No hay nuevos mensajes sin leer en este tema. Problema con abbc3

    martinkly

    2

    256

    13 Mar 2012 00:54

    martinkly Ver último mensaje

    Este tema está cerrado, no puede editar mensajes o enviar nuevas respuestas Problema con links en el foro

    frankspeed

    7

    314

    09 Jun 2010 21:08

    blquack Ver último mensaje

     


    ¿Quién está conectado?

    Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado

     
     

     
    No puede abrir nuevos temas en este Foro
    No puede responder a temas en este Foro
    No puede editar sus mensajes en este Foro
    No puede borrar sus mensajes en este Foro
    No puede enviar adjuntos en este Foro

    Buscar:
    Saltar a:  
    cron